can not connect to fcgi server

Topics: Developer Forum, Other Ruby On Rails Related Topics
Nov 29, 2007 at 8:47 AM
6) Make sure the file C:\WINDOWS\system32\libfcgi.dll exists and has execute permissions for NETWORK SERVICE.

hello friends, would you please tell me how to give permission to libfcgi.dll? i an on server 2003. thank you :)
Dec 3, 2007 at 4:30 PM

Just in case your still looking for this info...
Navigate to C:\WINDOWS\system32\
scroll down to libfcgi.dll
right-click and choose Properties
click the Security tab
click Add
Make sure the machine name is appearing in the 'From this location' field, if not click the Locations... button and select the local machine
type in NETWORK SERVICE
click Check Names... to verify the name is entered correctly
Click OK.
Check the Read & Execute checkbox



anguskwan wrote:
6) Make sure the file C:\WINDOWS\system32\libfcgi.dll exists and has execute permissions for NETWORK SERVICE.

hello friends, would you please tell me how to give permission to libfcgi.dll? i an on server 2003. thank you :)

Jan 16, 2009 at 1:43 AM
Edited Jan 16, 2009 at 2:17 AM
I have followed the instructions and have not been able to get Ruby working on IIS.  I have let the wizard do the install and manually setup the website in IIS.  When I go the default rails site and click the "about your application's environment" (http://sitename.com/rails/info/properties). I get the following error....

"Server Error, unable to connect to fastcgi server."

At one point I had 3 instances of rubyw.exe running w/ a route to dispatch.fcgi error, but in trying to fix that I feel I might have gone backwards.

I have been fighting w/ this for some time now and am about ready to install Apache and move on....I would really like to get this working on IIS,

Permissions are correctly set on libfcgi.dll and the ruby root directory for Network Service and IIS_WPG and I have followed everything else in the posts I have read. 

Unistalled and reinstalled multiple times....rewrite filter is loaded ok and isapi_fcgi.dll is set correctly.

???????????????????????

Any help is greatly appreciated!!

Using Server2k3

Derek
Jan 26, 2009 at 10:40 PM
Edited Jan 26, 2009 at 11:15 PM
now after resintalling once more I get the following error....

No route matches "/dispatch.fcgi" with {:method=>:get}
then i set the overwrite method and back to the can't connect to fastcgi server.


Im stuck and really don't wanna load apach